Back to overview
Downtime

Platform outage caused by upstream hosting provider incident

May 19, 2026 at 10:31pm UTC
Affected services
Core API
Third-Party Services
Writing Analysis
Learner UI
App & Authentication
Grade Post Webhook

Resolved
May 20, 2026 at 1:48am UTC

Resolved. Our hosting provider (Railway) experienced a multi-hour outage stemming from a Google Cloud disruption, which took the entire platform offline between approximately 6:31 PM and 9:48 PM ET. All services have been restored. No data was lost.

Created
May 19, 2026 at 10:31pm UTC

We are investigating a complete platform outage. The application, API, and related services are currently unavailable. We have identified the cause as an outage at our hosting provider and are monitoring for recovery.